패치업
 
home > 패치업 > 보안권고문
PHP 원격코드 실행 취약점 보안 업데이트 권고
2012-02-07 7345

□ 개요
o PHP 5.3.9 버전의 "php_register_variable_ex()" 함수에서 구현 오류로 인해 원격코드 실행 가능한
취약점이 발견됨[1]
o 공격자는 해당 취약점에 영향 받는 시스템에 특수하게 조작된 요청을 전송 할 경우, 영향받는
시스템에 원격코드를 실행시킬 수 있음
o 해당 취약점 정보 공개에 따라 피해를 입을 수 있으므로, 웹서버관리자의 적극적인 조치 필요

□ 해당 시스템
o 영향 받는 시스템
- PHP 5.3.9 버전

□ 해결방안
o 취약한 PHP 버전 사용자
- PHP 5.3.10 이상버전으로 업데이트 수행 [2]

□ 용어정리
o PHP : 동적인 웹사이트를 위한 서버 측 스크립트 언어

□ 기타 문의사항
o 한국인터넷진흥원 인터넷침해대응센터: 국번없이 118

[참고사이트]
[1] http://secunia.com/advisories/47806/
[2] http://www.php.net/
 
Untitled Document